Delivery Issue Norway Telia
Incident Report for 21st Century Mobile
Resolved
Telia Norway have been experiencing congestion issue in their network between 2020-03-12 and 2020-03-18.

Issue resolved at 2020-03-18.
Cause: Congestion issue likely caused by high loads.
Impact: Deliveries of SMS sent to recipients in Telia Norway's network where slightly delayed. Delivery reports for messages where delayed for two to three hours at times. No messages where lost.
Posted Mar 12, 2020 - 00:00 CET