Delivery Issue Norway Telia
Incident Report for 21st Century Mobile
Resolved
Some SMS sent to Norwegian (+47) numbers have been delivered more then once this morning. We have traced the issue to Telia Norway's network. The issue was reported and the response has been that the issue is now resolved.

Issue start: 2020-04-28 09:10
Issue resolved: 2020-04-28 09:40
Cause: Issue with Telia Norway's network.
Impact: Some SMS where delivered multiple times.
Posted Apr 28, 2020 - 14:22 CEST
This incident affected: Messaging platform (MyMSP) (Operator network).